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Mail merge is a very important facility provided by word processors, especially in the world of 
business and commerce. A single document (often a letter) is merged with a data set (often names 
and addresses) to produce several documents, each of which is personalized using information 
from the data set. At home this often arrives in the post as junk mail, but it could equally be a valid 
letter - eg a bank statement or reminder of a hospital appointment. A secretary at the bank/hospital 
hasn't typed out your letter personally; instead, they have used a mail merge to combine a standard 
letter and your details (along with those of other clients) to produce several letters at the same time. 

Mail merge can work with any dataset. The data may be held in a large database, in a spreadsheet 
or in a table in a document. You can even use tab-separated values in a very simple text file. This 
is then combined with a Word document which contains fields. The fields match the column 
headings in the table or spreadsheet. 

The aim of this document is to remove the mystery surrounding mail merge and to show you the 
facilities which Word provides to help you. 

Creating a Data Set 

As mentioned above, the data for a mail merge often comes from an outside source such as an 
Access database or Excel spreadsheet. You will be looking at these types of data source later. As 
an introduction to mail merge, create your own simple dataset as follows:  (This exercise uses 
school information for the example.) 

Start up Microsoft Word as usual  

1. Type in the following field headings, pressing <comma> between each entry: 
Title , FirstName , Surname , Department  

2. Press <Return> for a new line then type in a row of data (use your own details) pressing 
<comma> between each field (ie Mr , John , Smith , History)  

3. Repeat step 3 adding a title, first name, last name, and department.  
(ie Mrs , Donna , Jones , Spanish) 

4. Continue adding data for other people if you like (though 2 records is enough to demonstrate a 
mail merge) - don't press <Return> at the end of your last line of data  

5. Press <Ctrl s> for [Save] and call your file data.doc (press <Return> for [Save])  
6. Click on the [Close Window] button to close your document but leave Word running  

Creating the Merge Document 

You next need to create the merge document - here, a memo to be sent out to all those in your 
data file. In order to be able to enter field codes representing the data, you first have to associate 
the two documents together. You can, of course, write the bulk of the text without the codes (or use 
an existing document) and then add the codes later. Let's do that here: 

1. Press <Ctrl n> for [New] to create a new blank document  
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2. Type Memo to: then press <Tab> followed by <Return>  
3. Type Department: then press <Tab> followed by <Return>  
4. Click on the list arrow attached to the [Borders] button and select [Horizontal Line] (top row, 

far right)  
5. Click on the [Align Right] button then open the Insert menu and choose Date and Time...  
6. Select your preferred format from the Available formats: list then press <Return> for [OK]  
7. Press <Return> for a new line, click on [Align Left] then press <Return> again  

Now type in the following memo (or something similar): 

8. Type The next meeting of the Committee is next Friday at 2:00pm. Let me know if you 
can't make it.  

9. Press <Return> twice then sign off with your name  

Your document is now ready for data field codes to be added and for the merge to be carried out. 

The Mail Merge Toolbar 

 

There are two ways to carry out the mail merge - you can take command of the process yourself 
using buttons on a special Mail Merge toolbar or you can seek the help of a Wizard. Many find the 
latter less than helpful, especially if they don't understand what's going on, so try the toolbar first. 

1. Open the Tools menu and select Letters and Mailings and select Show Mail Merge Toolbar  
2. Click on the [Open Data Source] button - the second on the new toolbar  
3. Click on the [My Documents] button on the left side of the Open window  
4. Select the file data.doc then press <Return> for [Open]  

Nothing appears to have happened but your data file is now associated with the current document. 
Note how Word 2002 looked in a special folder (My Data Sources) for data files. When creating 
new ones, it's a good idea to store them in this folder (but you don't have to). 

5. Press <Ctrl Home> then <End> to move the typing position after Memo to:  
6. Now click on the [Insert Merge Fields] button (sixth along the toolbar)  
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7. Select Title then press <Return> for [Insert] followed by <Esc>  to close the Insert Merge 
Field window  

8. Press the <spacebar> then repeat steps 6 and 7, this time choosing FirstName  
9. Press the <spacebar> then repeat steps 6 and 7 for the Surname  
10. Press <down arrow> to move down to Department:  
11. Repeat steps 6 and 7, this time choosing Department  
12. Move the typing position down to the start of the first line of the memo (before The...)  
13. Repeat steps 6 and 7 again for the FirstName then type a ,  
14. End by pressing <Return> twice - your document is now ready for the merge  
15. Click on the [View Merged Data] button (to the right of [Insert Word Field])  

Your data fields should now have been replaced by real data. Further along the Mail Merge Toolbar 
is the [GoTo Record] button (currently displaying record number 1). To the left and right of this are 
buttons for [Previous Record] and [Next Record] (and [First Record] plus [Last Record]). 

17. Use the [Next Record] button to view the other memos  

Once you have checked the merged memos are correct you have a choice of either sending them 
directly to the printer or storing them in a new document. Towards the right of the Mail Merge Toolbar 
are the [Merge to New Document] and [Merge to Printer] buttons.  

18. Click on [Merge to New Document] - the following window appears:  
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You can now decide whether you want to have all the memos (records) or just some of them. You 
get the same dialog box if you choose [Merge to Printer]. 

19. Accept the All option - press <Return> for [OK]  

A new document called Letters1 appears, with a Section Break (New Page) separating each 
memo. You can edit the individual memos if you need to. 

20. Click on the [Close Window] button, saving the document as invites.doc  
21. End by clicking on the [View Merged Data] button to turn this off and return to the data field 

codes in your merge document  

When you closed the document, a Task Pane may have appeared on the far right of the screen. 
You'll be looking at this later, when you use the Wizard. To hide it, click on its [Close] button.  

Modifying the List of Recipients 

If you don't want all the records in your data file used in the merge (or, indeed, if you want to add 
further people), you can select the records you do want via the [Mail Merge Recipients] button: 

1. Click on [Mail Merge Recipients] - the third button on the Mail Merge toolbar  

The following window appears: 

 

To change any of the data or add a new recipient (or delete an existing one):  

2. Click on the [Edit...] button - a data form appears  
3. Click on [Add New], type in the data for the new recipient then click on [Close]  
4. Remove the tick from the check box in the top row (you don't need to send yourself a memo - 

this is how to remove individual recipients from the mail merge)  
5. Click on [OK] then on [View Merged Data] - note that record 1 is missing and that an extra 

memo has been added for the new recipient  
6. Click on [View Merged Data] again (there's no need to [Merge to New Document])  
7. End by closing the file - click on the [Close Window] button  
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8. When asked, save the changes you've just made to your data file, data.doc, (press <Return> 
for [Yes]) and save the merge document as memo.doc  

If you open up your data file, you will find that an extra record has been added and that your own 
record is still intact - turning off the check box doesn't delete the record from the file (you would 
have had to use the [Delete] button on the Data Form to do that). To see this: 

9. Open the File menu and select data.doc from the list of recently-opened files  

Note how double quotes have been placed around the data for the extra recipient. In this simple 
comma-separated file, these cause no problem. If, however, the text is converted to a proper table 
then they do appear in the merge: 

10. Press <Ctrl a> to select all the data  
11. Open the Table menu, choose Convert then Text to Table...  
12. Press <Return> for [OK] and the text becomes a proper table  

When performing a mail merge, people often create tables like this in which to store their data. As 
you have already seen, you don't have to do this - but it can simplify data entry. To check that the 
mail merge is still working: 

13. Press <Ctrl s> to save your new layout then use [Close Window] to close the data file  
14. Open the File menu and select memo.doc from the list of recently-opened files  
15. Click on the [View Merged Data] button - all the previous settings are retained  
16. Move to the last record and note that the double quotes now appear (they will need removing) 
17. Do a find and replace to remove quotes. 
18. End by clicking on [View Merged Data] again to see the data field codes once more  

The Address Block and Greeting Line 

One very annoying feature of mail merge in Word 2002 is not being able to display the list of data 
fields permanently. Each time you added a field, you had to click on the [Insert Merge Field] button 
then close the list to continue typing the merge document. To overcome this problem, Word 
provides two special codes (Address Blocks and Greeting Lines) to allow you to insert multiple data 
fields.  

1. Remove the current codes - drag through the three codes after Memo to: and <Delete> them  
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2. Next click on the [Insert Address Block] button - the fourth on the toolbar  

 

3. Here you require just the recipient's name, so turn off the Insert company name and Insert 
postal address options  

4. Press <Return> for [OK] to accept the default Format - the block is added to your memo  

Each Address Block can be customized and you can use this method to insert different fields at 
various locations in your document. Try adding another block for the Department: 

5. Remove the current code by dragging through <<Department>> and pressing <Delete>  
6. Repeat steps 2 and 3 but this time turn off Insert recipient's name and Insert postal address  

Though you haven't got a Company Name field, you can create one by matching an existing one: 

7. Click on [Match Fields...]  
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8. Click on the list arrow against Company and select Department  
9. Press <Return> then click on [OK] to enforce the change and insert the new block  
10. Click on [View Merged Data] to see the result then again to return to the codes  

Next, add a Greeting Line 

11. Move down to the start of the memo and <Delete> the first line (<<FirstName>>,)  
12. Click on the [Insert Greeting Line] button - the fifth on the toolbar  

 

13. Using the list arrow, change Mr. Randall to Joshua then press <Return> for [OK]  
14. Click on [View Merged Data] to see the result then again to return to the codes  
15. Click on [Close Window] to close memo.doc, saving the changes when asked  

End by turning off the Mail Merge Toolbar: 
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16. Open the View menu, choose Toolbars then click on Mail Merge  

The Mail Merge Wizard 

The Mail Merge Wizard takes you through the above process one step at a time, there are 6 steps 
in all. Once you are used to it, it makes mail merge even simpler. If you ever need to take control 
yourself then simply redisplay the toolbar and make the necessary changes using the buttons. 

1. Press  <Ctrl n> for a new document (a document must be open for the Wizard to work) then 
open the Tools menu, choose Letters and Mailings then Mail Merge Wizard...  

The Task Pane appears on the right of the screen. This changes with each step, as shown below: 

1)  

 

2)  

 

3)  

 

4)  

 

5)  

 

6)  
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Step 1: Setting Up the Document Type 

You haven't considered document type yet (though the first button on the Mail Merge toolbar also 
sets this). Basically, mail merge can be used for different types of document including a letter (or 
ordinary document), a set of envelopes, address labels and a list/catalogue (directory). The default 
type of document is a letter and, to keep things simple, that's what you'll create first:  

2. Leave document type as Letters - click on Next: Starting document at the foot of the pane  

Step 2: Select the Starting Document 

In step 2 you can choose which document you want for your merge document. This can be an 
existing document (or template) or the current document. 

3. Leave starting document as Use the current document - click on Next: Select recipients  

Step 3: Select Recipients 

In step 3 you need to identify the data file containing the recipients. If no such file currently exists 
then you can create one - try this next: 

4. Under Select recipients click on Type a new list then Create... - a data form appears:  

 

This provides a list of the most likely fields you will be using - but it's set up for writing a letter and 
uses American field names. That's no real problem as you can customize the list to rename fields, 
delete ones you don't want and add new ones you do require: 

5. Click on [Customize...] - another dialog box appears:  
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6. Select Company Name then click on [Rename]  

 

7. In To: type in a new name of Department then press <Return> for [OK]  
8. Next, select E-mail Address and [Delete] it - press <y> for [Yes] to confirm this  
9. Repeat step 8 eight times to leave just the first four fields in the list  
10. Now create an extra field - click on [Add...]  

 

11. Type in a new field name Partner then press <Return> for [OK]  

Note: Use the [Move Up] / [Move Down] buttons to alter the order of the fields on the form. 

12. Press <Return> for [OK] again to return to the form then enter some data, as you did earlier, 
starting with yourself - for just some of the recipients include their partner's first name  
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Tip: If you press <Return> (or <Tab>) at the end of each form it takes you to the [New Entry] 
button. Press <Return> again and you can enter your next set of data. 

13. When you have added 3 or 4 recipients, click on [Close]  
14. Save the address list in My Data Sources, calling it newdata (press <Return> for [Save]) - 

note that this file uses an Access database format  
15. The Mail Merge Recipients window now appears, allowing you to specify exactly which 

recipients you want - here, click on [OK] to accept them all  
16. Move on by clicking on Next: Write your letter  

Step 4: Write Your Letter 

You now have to write your letter. Again, try writing a memo similar to earlier: 

17. Type Memo to: then press <Tab>  
18. In the Task Pane, click on Address block... - turn off Insert company name and Insert postal 

address then press <Return> for [OK]  
19. Press <Return> for a new line, type Department: then press <Tab>  
20. In the Task Pane, click on More items... to see the list of merge fields  
21. Select Department, press <Return> for [Insert] then <Esc> to close Insert Merge Field  
22. Press <Return> for a new line then click on the [Horizontal Line] button  
23. Press <Return> for a new line then click on Greeting line... in the Task Pane  
24. Change the format from Mr. Randell to Joshua and Cynthia then click on [Match fields...]  
25. Using the list arrow provided, change Spouse First Name to Partner then press <Return> for 

[OK] - click on [OK] to insert the Greeting line code  
26. Press <Return> twice then type in a short memo: Don't forget the meeting on Friday  
27. Again, press <Return> twice then sign off with your name  
28. Move on by clicking on Next: Preview your letters  

Step 5: Preview Your Letters 

The fifth step of the Wizard allows you to preview the results of the merge. 

29. Use the Recipient buttons in the Task Pane to move between the memos  
30. When you reach the memo to yourself, click on [Exclude this recipient] - you don't need one  
31. Click on Edit recipient list... if you want to make any further changes to the list of recipients - 

click on [OK] to return to the merge  
32. Click on Next: Complete the merge to move on  

Step 6: Complete the Merge 

The final step of the merge allows you to send the letters to the printer (Print...) or edit individual 
letters (as you saw earlier). The latter is equivalent to Merge to New Document: 
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33. Click on Edit individual letters... in the Task Pane  
34. Accept the default option All - press <Return> for [OK]  
35. Click on the [Close Window] button - there's no need to save Letters2.doc  

Labels, Envelopes and Directories 

The first step of the Wizard was to choose a document type. The default type is a Letter. In this 
next section, have a look at the other types: 

1) Labels 

If you want the mail merge to produce a set of labels then you proceed as follows: 

1. Press <Ctrl n> for a new starting document  
2. Open the Tools menu, select Letters and Mailings then Mail Merge Wizard...  
3. At step 1 of the Wizard, choose Labels then click on Next: Starting document  
4. Click on Label options... to set up your labels:  

 

5. Change the Label products: (manufacturer) if necessary then select the correct Product 
number: (eg Avery standard and 5160) - press  <Return> for [OK]  

6. Click on Next: Select recipients  
7. Use an existing list and click on Browse... to find it  
8. Select newdata.mdb and [Open] it  
9. Click on [OK] to close the Mail Merge Recipients window  

A skeleton set of labels is displayed with all but the first containing the special <<Next Record>> 
code.  
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10. Click on Next: Arrange your labels  
11. Click on Address block... and set Insert recipient's name only - press <Return> for [OK]   

You now have the correct field codes on the first label but the others are all empty. Were you to 
view the labels, just one label per sheet would show. The <<Next Record>> code moves on to the 
next recipient but no details are included on the label. You need to replicate the codes on each 
label: 

14. Click on the down arrow at the very foot of the Task Pane to move the pane down   
15. Click on the [Update all labels] button (or use [Propagate Labels] on the Mail Merge toolbar) 

- the field codes are copied to all the labels  
16. Click on Next: Preview your labels to view the actual labels  
17. End by closing the current document - click on [Close Window] - there's no need to save it  

2) Envelopes 

A similar process to the above could be used to print mail merge data on a set of envelopes. 
There's no need to go through the whole process in these notes but it is worth looking at the initial 
steps: 

1. Press <Ctrl n> for a new starting document  

2. Open the Tools menu, select Letters and Mailings then Mail Merge Wizard...  
3. At step 1 of the Wizard, choose Envelopes then click on Next: Starting document  
4. Click on Envelope options... to set up your envelopes:  

The Envelope Options window has two tabs as shown below: 

 

` 
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On these you need to set up the correct Envelope size: and the Feed method for your particular 
printer. Note also the Preview envelope. This has an area for the Return address at the top left and 
for the Delivery address in the lower middle. You can change the settings for these if you need to. 

5. Select an Envelope size: of DL then press <Return> for [OK]  
6. The current typing position is ready for you to type in your Return address (if you want one)  
7. Move the mouse cursor over the position of the Delivery address (lower centre of envelope) 

and click to reset the typing position into the text box provided  

You would now link in the data file and insert an <<Address Block>> but there's no need to here. 

8. End by closing the current document - click on [Close Window] - there's no need to save it  

Note: Once you have set up the Envelope options for one mail merge, Word remembers the 
settings for future merges. Similarly, Labels options are retained from one merge to the next. 

3) Directories 

You can merge data into a list such as a catalogue or list of members.  Word calls such a 
document a directory. If you select this option at step 1 of the Wizard then you are forced into 
creating a new document at step 6 (you don't have the option of printing the merged records 
directly to the printer). 

1. Press <Ctrl n> for a new starting document  
2. Open the Tools menu, select Letters and Mailings then Mail Merge Wizard...  
3. At step 1 of the Wizard, choose Directory then click on Next: Starting document  
4. Click on Next: Select recipients  
5. Use an existing list and click on Browse... to find it  
6. Open newdata.mdb 
7. Click on [OK] to close the Mail Merge Recipients window  
8. Click on Next: Arrange your directory  
9. In the Task Pane, click on Address block... setting this to Insert recipient's name only - press 

<Return> for [OK]  
10. Press <Return> for a new line then click on More items... in the Task Pane  
11. Choose Department, press <Return> for [Insert] then <Esc> to close the list of fields  
12. Press <Return> twice for new lines  

Your document is now set up for the merge. The list only shows when you get to the final step of 
the Wizard so, to speed things up, use the toolbar button to carry out the merge: 

13. Click on the [Merge to New Document] button - press <Return> for [OK] for All records  
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You should find that you now get a list, with several records on each page.  

14. Close the merged file by clicking on [Close Window] - there's no need to save it  

You could equally well have used a one-row table for your merge document, in which case you 
would now have a complete table. If you wanted your table to have column headings, you would 
add them to the final document, not the merge document. To see this: 

15. Click on the [Insert Table] button and create a 1 x 2 Table (one row, two columns)  
16. Drag through the <<Address Block>> code to select it then drag and drop it into the left-hand 

cell of the table (or use [Cut] and [Paste])  
17. Repeat step 16 for the <Department>> code and drop it into the right-hand cell  
18. <Delete> any excess empty lines either above, below or inside the table  
19. Click on the [Merge to New Document] button - press <Return> for [OK] for All records  
20. Now add the headings - open the Table menu and choose Insert then Rows Above  
21. Type the headings Name and Department and apply any formatting (eg [Bold] and [Center])  
22. Open the Table menu again, choose Table Properties... and click on the Row tab  
23. Turn on Repeat as header row at the top of each page then press <Return> for [OK]  
24. Scroll down your new document to see the result  

Word Fields 

Word has a small number of special field codes primarily for use with mail merge. You've already 
seen one (<<Next Record>>) but others allow you to type in additional data (ie not held in the data 
file) or display a particular data item only if it meets certain criteria. 

Start with the mailmerge wizard.  

1. Write the following letter: 

Dear first name 

To thank you for a job well done you will receive tickets for an all expense paid trip to . 

Sincerely, 

Your company president. 
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Using the Mail Merge Wizard: 
Open new document 
Select document type  – Letters  

Select starting Document 
Use the current  document 

Select recipients 
Type a new list 
Delete all fields except first name 
Add a field – “rank”  
Fill in a first_name and rank for eight records,  

put in for rank: 
1 for first record,     5 for second record,     2 for third record,     6 for fourth record,     3 for fifth record 
7 for sixth record,     4 for seventh record,     8 for eight record 
When prompted, save as ranks. 
 
Write Your Letter 
Hightlight the words “first name” in your letter and go to More Items and replace “first name” with the 
first_name field. 
To add the word field you need the mail merge toolbar.  If it is not showing, access through Tools on 
the menu, or right click on the gray bar above the ruler and click the box in front of Mail Merge. 
Click In your letter, after the word to (and before the period) then click on the [Insert Word Field] 
button and choose and choose if…Then…Else… 

  

Anyone with a rank lower that 4, will have the info “New York City” inserted, and anyone with a rank 
higher than 4 will get a trip to Hawaii. 
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5. Click on [OK] then on the [Merge to New Document]  button  
6. Press <Return> for [OK] to see All the records 
7. Check to see if everyone got the correct trip according to their rank. 
8. Close the merged file by clicking on [Close Window] - there's no need to save it  

Additional Tips 

Tip 1: Drop-Down Insert Merge Field Buttons 

In previous versions of Word, the Insert Merge Field button gave you a drop-down list of fields from 
which you could select the one you wanted. This was much easier to use as you could insert a 
merge field then immediately continue typing without having to close the Insert Merge Field window 
first. 

To reinstate the drop-down list on the Mail Merge toolbar: 

1. Click on the down arrow on the far right of the toolbar and choose Add or Remove Buttons 
then Mail Merge  

2. At the bottom of the list of buttons, turn on Insert Merge Field  
3. If you want to move the button to a different position, click on Customize...  
4. Drag and drop the button to the position you want (it was to the left of [Insert Word Field])  
5. Finally, [Close] the Customize window  

You now have the drop-down list for inserting fields. If you have no use for the [Insert Merge 
Fields] button, repeat steps 1 and  2 (as above) but at step 2 turn off Insert Merge Fields.  

Tip 3: Returning a Mail Merge Document back to Normal  

To reset a merge document to a normal one (ie release the link to the data source completely), use 
the [Main Document Setup] button (the first on the Mail Merge toolbar) and choose Normal Word 
document. 

 


